Another 3-D Editor Thread

Error message

Deprecated function: implode(): Passing glue string after array is deprecated. Swap the parameters in drupal_get_feeds() (line 394 of /var/www/
AuthorTopic: Another 3-D Editor Thread
Member # 6193
Profile Homepage #0
I just downloaded the 3-D editor for windows. I used it for a while, and found it to be useful, and a significant improvement over the old editor.

Unfortunately, it started getting kinda whacked out. I had spent most of my time editing one town, (town 5) and found no problems. However, when I loaded a new town I got an error message like "missing graphic 0 in sheet 36" (this was last night, but I'm pretty sure that it was something like that.) The editor proceeded in completely anhihalating the floors and terrain heights in about half my towns. It also removed all the terrain from all my outdoors.

Fortunately I am naturally distrustful of all new software, and had backed up my files just before launching the editor, else this would be a very angry post. As it is I would just like to know if I can expect this to happen regularly. I like the 3-D editor, but if other people have seen this problem and it is a routine one, then I'll have to do without.

Guaranteed to blow your mind.

Frostbite: Get It While It's...... Hot?
Posts: 900 | Registered: Monday, August 8 2005 07:00
The Establishment
Member # 6
Profile #1
This is the first I've heard of it. Try uninstalling and redownloading and see what happens.

Your flower power is no match for my glower power!
Posts: 3726 | Registered: Tuesday, September 18 2001 07:00
Shock Trooper
Member # 4445
Profile #2
Also make sure that you're not placing doors, windows etc. from a wallset that doesn't have them. That pisses it off.
Posts: 293 | Registered: Saturday, May 29 2004 07:00
Member # 4506
Profile Homepage #3
Hmm. I had the editor do something similar once when a graphic was whacked. When I fixed the graphics, it fixed itself. Dunno why, but it did. Oddly enough, I've never been able to reproduce the error (not that I've wanted to).

- Archmagus Micael

"You dare Trifle with Avernum?" ~ Erika the Archmage
My Scenarios:
Undead Valley : A small Undead problem, what could possibly go wrong?
Richard Black - PROOF of his existance (the Infernal one's website).
MY FORUM! Randomosity at it's highest! :)
Posts: 1370 | Registered: Thursday, June 10 2004 07:00
Law Bringer
Member # 4153
Profile Homepage #4
Did all of it actually disappear, or did the graphics just go away? And was the graphic being referred to a custom one?

Gamble with Gaea, and she eats your dice.

I hate undead. I really, really, really, really hate undead. With a passion.
Posts: 4130 | Registered: Friday, March 26 2004 08:00
Member # 6193
Profile Homepage #5
It was very strange, because the only town I had worked on was town 5, and I hadn't changed the graphics at all.

The floors in several dungeons were indiscriminately swapped, mostly with blackness, and without any rhyme or reason, some terrain was messed with as well. The heights were set to 0 throughout the town, with a few strips of 255 height. All the terrain was deleted from outdoors.

It was strange because as I said, I hadn't changed the graphics at all. I reverted to my back up file, which had the same graphics, and it ran fine. I might just write it off a a fluke; unless the problem repeats itself.

Guaranteed to blow your mind.

Frostbite: Get It While It's...... Hot?
Posts: 900 | Registered: Monday, August 8 2005 07:00
Member # 3442
Profile Homepage #6
I used to have this problem all the time - I think I downloaded the latest version and it worked.

Of course, make sure that if you have defined any custom items/terrain etc, your custom terrain script points to the right file, and that the graphics files are actually there - that might do it.

And when you want to Live
How do you start?
Where do you go?
Who do you need to know?

*Name by Slarty, so blame him if it's filthy...
Posts: 2864 | Registered: Monday, September 8 2003 07:00