3D Editor Crash

AuthorTopic: 3D Editor Crash
Law Bringer
Member # 4153
Profile Homepage #0
Alright... rather impressive error with the 3D Editor. Everything loads fine, I can edit terrain just fine.

But for some reason, whenever I close a window (such as the Town Details window), the editor crashes. Very repeatable, very inexplicable.

I'm working on a Mac, running OS 10.4.5. And this is fairly low-priority, since the regular editor still works. And this computer isn't even mine, since mine is under repair currently (I'm running BoA, the Editor, and the 3D Editor from my iPod in hard disk mode).

--------------------
Gamble with Gaea, and she eats your dice.

I hate undead. I really, really, really, really hate undead. With a passion.
Posts: 4130 | Registered: Friday, March 26 2004 08:00
Shock Trooper
Member # 4557
Profile #1
This bug was fixed in the latest version of the 3D Editor. You're probably using an older version.
Posts: 264 | Registered: Wednesday, June 16 2004 07:00
Master
Member # 5977
Profile Homepage #2
Can one run a game such as BoA from an Ipod!? Wow... How can one do that?

--------------------
Play and rate my scenarios:

Where the rivers meet
View my upcoming scenario: The Nephil Search: Escape.

Give us your drek!
Posts: 3029 | Registered: Saturday, June 18 2005 07:00
Law Bringer
Member # 4153
Profile Homepage #3
quote:
Originally written by KernelKnowledge12:

This bug was fixed in the latest version of the 3D Editor. You're probably using an older version.
I have version 1.02b5, the most recent one from the SourceForge site. I can't find anything newer.

(Side note: It'd be helpful if a mod would put a link to the BoA Utilities page in the forum header somewhere.)

quote:
Originally written by Thralni:

Can one run a game such as BoA from an Ipod!? Wow... How can one do that?
Well, it's technically not running on the iPod. Using the iPod as an external hard disk, one can keep BoA, the editors, ResEdit, whatever one needs close at hand. However, one must also keep the preference files on the disk as well, to be inserted wherever necessary on the host computer (to avoid legal complications, I remove them whenever I'm done working).

(Side note: using "one" is way more fun than using "you".)

--------------------
Gamble with Gaea, and she eats your dice.

I hate undead. I really, really, really, really hate undead. With a passion.
Posts: 4130 | Registered: Friday, March 26 2004 08:00
Shock Trooper
Member # 4557
Profile #4
quote:
Originally written by Ephesos:

I have version 1.02b5, the most recent one from the SourceForge site. I can't find anything newer.

Version 1.02b6: http://tinyurl.com/fjjr2

Note: It has 1.02b5 in the Application's title bar, but it is version 1.02b6.
Posts: 264 | Registered: Wednesday, June 16 2004 07:00
Shaper
Member # 3442
Profile Homepage #5
Is there a way to turn off the sound in the 3D Editor? Whenever I load up BoA to test, and then come back to the 3D Editor, it tells me that it can't play sounds, and then freezes. Which is annoying.

--------------------
And when you want to Live
How do you start?
Where do you go?
Who do you need to know?

Posts: 2864 | Registered: Monday, September 8 2003 07:00
Shaper
Member # 5437
Profile #6
The same thing happened to me after switching to Tiger (while using version 1.02b5). Downloading the same version I had before and throwing away the old one fixed it.

Actually, I had to do the same thing with A3.
Posts: 2032 | Registered: Wednesday, January 26 2005 08:00
Law Bringer
Member # 4153
Profile Homepage #7
Alright... it works again. Yay.

--------------------
Gamble with Gaea, and she eats your dice.

I hate undead. I really, really, really, really hate undead. With a passion.
Posts: 4130 | Registered: Friday, March 26 2004 08:00
Shock Trooper
Member # 4557
Profile #8
quote:
Originally written by White Lady xx:

Is there a way to turn off the sound in the 3D Editor?
There is no way to turn off sound in the 3D editor. If you are having audio problems starting GarageBand tends to help for some reason.
Posts: 264 | Registered: Wednesday, June 16 2004 07:00
BANNED
Member # 6432
Profile #9
The 3D editor keeps quiting automaticly when i open it :mad: :mad: :mad:
Why :confused:

EDIT: Nevermind i just fixed it.

[ Tuesday, April 25, 2006 17:43: Message edited by: Bomber ]

--------------------
I hate you all
Posts: 165 | Registered: Friday, October 28 2005 07:00
Shaper
Member # 3442
Profile Homepage #10
quote:
Originally written by KernelKnowledge12:

quote:
Originally written by White Lady xx:

Is there a way to turn off the sound in the 3D Editor?
There is no way to turn off sound in the 3D editor. If you are having audio problems starting GarageBand tends to help for some reason.

I'm using Windows... It's not a major problem, it's just damn annoying.

--------------------
And when you want to Live
How do you start?
Where do you go?
Who do you need to know?

Posts: 2864 | Registered: Monday, September 8 2003 07:00
Shock Trooper
Member # 4557
Profile #11
I think I built a soundless editor for CPeters. Given he still has it, you could get a copy from him.
Posts: 264 | Registered: Wednesday, June 16 2004 07:00