3D Editor Crash

AuthorTopic: 3D Editor Crash
Off With Their Heads
Member # 4045
Profile Homepage #0
My 3D Editor won't open anymore. When I double-click on it, it begins to open, starts showing the editor, and then closes. It pops up an error messages that says, "The application 3D Blades of Avernum Editor has unexpectedly quit." It gives me the option to submit a bug report to Apple, and then it gives this description:

Date/Time: 2005-07-22 14:13:48 -0700
OS Version: 10.3.9 (Build 7W98)
Report Version: 2

Command: 3D Blades of Avernum Editor
Path: /Games/Spiderweb/Blades of Avernum v1.0/Blades of Avernum Editor v1.1/3D Blades of Avernum Editor1.02b6/3D Blades of Avernum Editor.app/Contents/MacOS/3D Blades of Avernum Editor
Version: v1.02b5 (v1.02b5)
PID: 513
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x0000001e

Thread 0 Crashed:
0 com.spidweb.BoA3DEditor 0x0003e5b4 load_sounds() + 0x7c
1 com.spidweb.BoA3DEditor 0x00030820 main + 0x7c
2 com.spidweb.BoA3DEditor 0x000085a4 _start + 0x188 (crt.c:267)
3 dyld 0x8fe1a278 _dyld_start + 0x64

Thread 1:
0 libSystem.B.dylib 0x90007878 mach_msg_trap + 0x8
1 libSystem.B.dylib 0x900073f8 mach_msg + 0x38
2 com.apple.CoreFoundation 0x901c16e0 __CFRunLoopRun + 0x350
3 com.apple.CoreFoundation 0x901c5e6c CFRunLoopRunSpecific + 0x148
4 com.apple.audio.CoreAudio 0x911104b8 HALRunLoop::OwnThread(void*) + 0x104
5 com.apple.audio.CoreAudio 0x911102ec CAPThread::Entry(CAPThread*) + 0x30
6 libSystem.B.dylib 0x90024910 _pthread_body + 0x28

PPC Thread State:
srr0: 0x0003e5b4 srr1: 0x0200f030 vrsave: 0x00000000
cr: 0x24000228 xer: 0x00000000 lr: 0x0003e5a0 ctr: 0x90000c78
r0: 0x00000080 r1: 0xbffffc60 r2: 0x00000000 r3: 0xfffff82c
r4: 0x00000000 r5: 0x00000005 r6: 0x00000000 r7: 0x00000000
r8: 0x00000000 r9: 0xa00016b4 r10: 0x018001c8 r11: 0x01800010
r12: 0x90000c78 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
r16: 0x00000000 r17: 0x00000000 r18: 0x00000000 r19: 0x00000000
r20: 0x00000000 r21: 0x00000000 r22: 0x00000000 r23: 0x00000000
r24: 0x00000000 r25: 0x00000000 r26: 0xbffffdb0 r27: 0x0000000c
r28: 0x00000000 r29: 0x001648d0 r30: 0xbffffdc0 r31: 0x00000001

Binary Images Description:
0x1000 - 0x55fff com.spidweb.BoA3DEditor v1.02b5 /Games/Spiderweb/Blades of Avernum v1.0/Blades of Avernum Editor v1.1/3D Blades of Avernum Editor1.02b6/3D Blades of Avernum Editor.app/Contents/MacOS/3D Blades of Avernum Editor
0x6d0000 - 0x709fff com.apple.audio.SoundManager.Components 3.9.1 /System/Library/Components/SoundManagerComponents.component/Contents/MacOS/SoundManagerComponents
0x713000 - 0x714fff com.apple.aoa.halplugin 2.5.0 /System/Library/Extensions/IOAudioFamily.kext/Contents/PlugIns/AOAHALPlugin.bundle/Contents/MacOS/AOAHALPlugin
0x753000 - 0x785fff com.apple.iSightAudio 7.0.1 /Library/Audio/Plug-Ins/HAL/iSightAudio.plugin/Contents/MacOS/iSightAudio
0x80830000 - 0x8090efff libxml2.2.dylib /usr/lib/libxml2.2.dylib
0x8fe00000 - 0x8fe4ffff dyld /usr/lib/dyld
0x90000000 - 0x9014ffff libSystem.B.dylib /usr/lib/libSystem.B.dylib
0x901c0000 - 0x9026dfff com.apple.CoreFoundation 6.3.7 (299.35) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x902b0000 - 0x90529fff com.apple.CoreServices.CarbonCore 10.3.7 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore
0x90584000 - 0x905f3fff com.apple.framework.IOKit 1.3.6 (???) /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x90610000 - 0x9069afff com.apple.CoreServices.OSServices 3.0.1 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
0x90700000 - 0x90700fff com.apple.CoreServices 10.3 (???) /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
0x907f0000 - 0x907f9fff com.apple.DiskArbitration 2.0.5 /System/Library/PrivateFrameworks/DiskArbitration.framework/Versions/A/DiskArbitration
0x90810000 - 0x90810fff com.apple.ApplicationServices 1.0 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
0x90830000 - 0x9089ffff libobjc.A.dylib /usr/lib/libobjc.A.dylib
0x908c5000 - 0x90915fff com.apple.HIServices 1.4.1 (0.0.1d1) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/HIServices.framework/Versions/A/HIServices
0x90940000 - 0x909b3fff com.apple.DesktopServices 1.2.5 /System/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A/DesktopServicesPriv
0x909f0000 - 0x90a08fff com.apple.WebServices 1.1.1 (1.1.0) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/WebServicesCore.framework/Versions/A/WebServicesCore
0x90a20000 - 0x90b7bfff com.apple.Foundation 6.3.7 (500.59) /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
0x90c32000 - 0x90c45fff com.apple.speech.synthesis.framework 3.2 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/SpeechSynthesis.framework/Versions/A/SpeechSynthesis
0x90d00000 - 0x90d1bfff com.apple.SystemConfiguration 1.7.1 (???) /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
0x90d40000 - 0x90d40fff com.apple.Carbon 10.3 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
0x910b0000 - 0x91101fff com.apple.bom 1.2.5 (63.2) /System/Library/PrivateFrameworks/Bom.framework/Versions/A/Bom
0x9110d000 - 0x91174fff com.apple.audio.CoreAudio 2.1.3 /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
0x912e0000 - 0x912f7fff com.apple.LangAnalysis 1.5.4 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LangAnalysis.framework/Versions/A/LangAnalysis
0x91303000 - 0x9136cfff com.apple.htmlrendering 1.1.2 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HTMLRendering.framework/Versions/A/HTMLRendering
0x913a0000 - 0x9145ffff ColorSync /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ColorSync.framework/Versions/A/ColorSync
0x915e0000 - 0x91699fff com.apple.QD 3.4.67 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/QD.framework/Versions/A/QD
0x916e0000 - 0x91773fff com.apple.print.framework.PrintCore 3.3 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/PrintCore.framework/Versions/A/PrintCore
0x917b6000 - 0x917cafff libCGATS.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCGATS.A.dylib
0x917e0000 - 0x917f0fff com.apple.speech.recognition.framework 3.3 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SpeechRecognition.framework/Versions/A/SpeechRecognition
0x91810000 - 0x9182afff com.apple.openscripting 1.2.1 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/OpenScripting.framework/Versions/A/OpenScripting
0x91850000 - 0x91860fff com.apple.ImageCapture 2.1.5 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/ImageCapture.framework/Versions/A/ImageCapture
0x91890000 - 0x9189cfff com.apple.help 1.0.1 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Help.framework/Versions/A/Help
0x918c0000 - 0x918cdfff com.apple.CommonPanels 1.2.1 (1.0) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CommonPanels.framework/Versions/A/CommonPanels
0x918f0000 - 0x9193efff com.apple.print.framework.Print 3.3 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Print.framework/Versions/A/Print
0x91990000 - 0x9199bfff com.apple.securityhi 1.2 (90) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SecurityHI.framework/Versions/A/SecurityHI
0x91a40000 - 0x91ab3fff com.apple.NavigationServices 3.3.3 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/NavigationServices.framework/Versions/A/NavigationServices
0x91b10000 - 0x91b2afff libPDFRIP.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libPDFRIP.A.dylib
0x91b50000 - 0x91b5ffff libPSRIP.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libPSRIP.A.dylib
0x91b80000 - 0x91b93fff libRIP.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libRIP.A.dylib
0x92070000 - 0x92096fff com.apple.FindByContent 1.4 (1.2) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/FindByContent.framework/Versions/A/FindByContent
0x920c0000 - 0x922a7fff com.apple.security 2.4 (177) /System/Library/Frameworks/Security.framework/Versions/A/Security
0x923c4000 - 0x923fcfff com.apple.AE 1.4 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/AE.framework/Versions/A/AE
0x92430000 - 0x92468fff com.apple.LaunchServices 10.3.5 (98.4) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/LaunchServices
0x927b2000 - 0x927e0fff libssl.0.9.7.dylib /usr/lib/libssl.0.9.7.dylib
0x927f0000 - 0x92827fff com.apple.CFNetwork 1.2.1 (7) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork
0x92880000 - 0x92c05fff com.apple.HIToolbox 1.3.6 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox
0x939a0000 - 0x939b4fff libcups.2.dylib /usr/lib/libcups.2.dylib
0x939d0000 - 0x939d4fff libmathCommon.A.dylib /usr/lib/system/libmathCommon.A.dylib
0x93b3c000 - 0x93bf4fff com.apple.audio.toolbox.AudioToolbox 1.3.3 /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
0x9415d000 - 0x94168fff libCSync.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCSync.A.dylib
0x945b0000 - 0x945b9fff libz.1.dylib /usr/lib/libz.1.dylib
0x94610000 - 0x9462afff libresolv.9.dylib /usr/lib/libresolv.9.dylib
0x94650000 - 0x946affff com.apple.SearchKit 1.0.2 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchKit.framework/Versions/A/SearchKit
0x94800000 - 0x9488cfff com.apple.ink.framework 101.1.4 (55.12) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Ink.framework/Versions/A/Ink
0x954c0000 - 0x95ac6fff libBLAS.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
0x95b20000 - 0x95df0fff libLAPACK.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib
0x95e0a000 - 0x95e27fff com.apple.audio.SoundManager 3.9 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CarbonSound.framework/Versions/A/CarbonSound
0x95e40000 - 0x95eadfff libvDSP.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvDSP.dylib
0x95f00000 - 0x95f20fff libvMisc.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvMisc.dylib
0x96499000 - 0x96771fff com.apple.CoreGraphics 1.203.30 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics
0x968d0000 - 0x969b2fff libicucore.A.dylib /usr/lib/libicucore.A.dylib
0x96a20000 - 0x96ae2fff libcrypto.0.9.7.dylib /usr/lib/libcrypto.0.9.7.dylib
0x96b2e000 - 0x96b36fff libbsm.dylib /usr/lib/libbsm.dylib
0x96b50000 - 0x96bdffff ATS /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/ATS
0x96cb0000 - 0x96d9efff libiconv.2.dylib /usr/lib/libiconv.2.dylib
0x96e80000 - 0x96e90fff com.apple.vecLib 3.0.3 (vecLib 3.0.3) /System/Library/Frameworks/vecLib.framework/Versions/A/vecLib
0x9798b000 - 0x9798bfff com.apple.audio.units.AudioUnit 1.3.3 /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit
I'm running Mac OS 10.3.9. I'm using the latest version of the 3D Editor, and reinstalling doesn't help. Nor does restarting or closing all other applications. I can't recall installing any system software recently, but I may have had some sort of auto-update or something.

Any ideas?

EDIT: And oddly enough, no version of the 3D Editor will open. They all do the same thing.

EDIT 2: What the heck? BoA won't open either. Gah, time to try re-downloading that.

EDIT 3: I did download a demo of BoA and install it to check if VoDT had been fixed, which seem related. It was installed in a completely different folder, and I'm not opening that copy, though.

[ Friday, July 22, 2005 12:25: Message edited by: Kelandon ]

--------------------
Arancaytar: Every time you ask people to compare TM and Kel, you endanger the poor, fluffy kittens.
Smoo: Get ready to face the walls!
Ephesos: In conclusion, yarr.

Kelandon's Pink and Pretty Page!!: the authorized location for all things by me
The Archive of all released BoE scenarios ever
Posts: 7968 | Registered: Saturday, February 28 2004 08:00
Shock Trooper
Member # 4557
Profile #1
quote:
Originally written by Kelandon:


EDIT: And oddly enough, no version of the 3D Editor will open. They all do the same thing.

EDIT 2: What the heck? BoA won't open either. Gah, time to try re-downloading that.

EDIT 3: I did download a demo of BoA and install it to check if VoDT had been fixed, which seem related. It was installed in a completely different folder, and I'm not opening that copy, though.

Sounds like a corrupted resource file, although I could definitely be wrong. Check if the demo of BoA works.
Posts: 264 | Registered: Wednesday, June 16 2004 07:00
Off With Their Heads
Member # 4045
Profile Homepage #2
It does not work either.

--------------------
Arancaytar: Every time you ask people to compare TM and Kel, you endanger the poor, fluffy kittens.
Smoo: Get ready to face the walls!
Ephesos: In conclusion, yarr.

Kelandon's Pink and Pretty Page!!: the authorized location for all things by me
The Archive of all released BoE scenarios ever
Posts: 7968 | Registered: Saturday, February 28 2004 08:00
Shock Trooper
Member # 4557
Profile #3
Any other programs fail?
Posts: 264 | Registered: Wednesday, June 16 2004 07:00
Off With Their Heads
Member # 4045
Profile Homepage #4
Nope, not that I've noticed.

--------------------
Arancaytar: Every time you ask people to compare TM and Kel, you endanger the poor, fluffy kittens.
Smoo: Get ready to face the walls!
Ephesos: In conclusion, yarr.

Kelandon's Pink and Pretty Page!!: the authorized location for all things by me
The Archive of all released BoE scenarios ever
Posts: 7968 | Registered: Saturday, February 28 2004 08:00
Shock Trooper
Member # 4557
Profile #5
Do you have the original editor? If so check if that works. (It shouldn't.)

Other than this, I'm pretty much at a loss. If both BoA and the editor don't work the problem is either with the files they share or any calls to Carbon they share. If no other programs (except those relevent to BoA) fail, then the problem should be with the files they share.

Can you build the source to the Editor?
Posts: 264 | Registered: Wednesday, June 16 2004 07:00
Warrior
Member # 3340
Profile #6
Kelandon,

here is a real dumb question for you...

Was the 3d editor working the last time that you used it? If so, try to think what you were doing when you closed the editor. Was the file(s) saved correctly?

Please ignore -- thinking out loud..... :P

Did told you it was a dumb question.......

James

--------------------
Sometimes I just don't know anything about everything -- or do I ?
Posts: 99 | Registered: Wednesday, August 13 2003 07:00
Off With Their Heads
Member # 4045
Profile Homepage #7
The original editor does not work either.

I have Xcode, but I have very little idea how to use it. With detailed instructions, I could build the source, but I wouldn't know how to do it myself.

The last thing I did with the editor was check the demo's version of VoDT. I chose not to save anything. It was working fine at that point.

--------------------
Arancaytar: Every time you ask people to compare TM and Kel, you endanger the poor, fluffy kittens.
Smoo: Get ready to face the walls!
Ephesos: In conclusion, yarr.

Kelandon's Pink and Pretty Page!!: the authorized location for all things by me
The Archive of all released BoE scenarios ever
Posts: 7968 | Registered: Saturday, February 28 2004 08:00
Infiltrator
Member # 4637
Profile Homepage #8
Try to install in a different folder. Maybe a damaged cluster in your HD? Defrag your HD.

--------------------
Visit the Blades of Avernum Center
and the Beta Testing Center

--------------
"Beware lest anyone cheat you through philosophy and empty deceit, according to the tradition of men, according to the basic principles of the world, and not according to Christ." Colossians 2:6-9
Posts: 483 | Registered: Tuesday, June 29 2004 07:00
...b10010b...
Member # 869
Profile Homepage #9
What files do BoA and the editors share, exactly? Given that two separate copies of BoA, in separate directories, both failed to work, it can't be anything in the BoA directory itself. A corrupted preference file seems the next obvious suggestion. Try looking in your preferences folder (Users/apple/Library/Preferences) and moving everything with "Blades of Avernum" in its name into the trash. If everything works again after that, the preferences were causing the problem; delete them. (Note: this will unregister BoA.)

[ Saturday, July 23, 2005 00:14: Message edited by: Thuryl ]

--------------------
The Empire Always Loses: This Time For Sure!
Posts: 9973 | Registered: Saturday, March 30 2002 08:00
Shock Trooper
Member # 4557
Profile #10
quote:
A corrupted preference file seems the next obvious suggestion.
The editor does not use this file, but it does need the graphics from BoA. According to the crash data, the editor stopped upon entering the function load_sound(), which is incredibly odd, and suggests that OS X, did something wrong. Did BoA or the original editor give data when it crashed?

quote:
Originally written by Kelandon:

The original editor does not work either.

I have Xcode, but I have very little idea how to use it. With detailed instructions, I could build the source, but I wouldn't know how to do it myself.

The last thing I did with the editor was check the demo's version of VoDT. I chose not to save anything. It was working fine at that point.

I've never used XCode, but from the tutorials on apple.com it seems pretty easy to use.

Here's the Quick Tour Guide:
http://developer.apple.com/documentation/DeveloperTools/Conceptual/XcodeQuickTour/ index.html

First you should get a copy of the Mac editor's source. I can email it to you if you can't access it from the CVS server. I'm not sure, but I think the XCode project file is in the editor, so if it is, open it. If not, you'll have to create it. After that you should just have to compile/build it. All of this should be in the first section of the quick tour guide.

After you successfully build it once, we can figure out exactly where the editor stopped working.
Posts: 264 | Registered: Wednesday, June 16 2004 07:00
Off With Their Heads
Member # 4045
Profile Homepage #11
Okay, so this is what I did:

I downloaded the source from Sourceforge. I looked through and found a .xcode file, and I figured that'd be the place to start building it. I opened it in Xcode, which popped up a promising-looking window. I went to the Build menu and chose "Build." It gave me this:

quote:
Compiling EdFcns.cpp (2 errors)
error: `UCHAR' undeclared
error: parse error before `.' token
Build failed (2 errors)
When I try to open the resulting application, I get this message: "You cannot open the application '3D Blades of Avernum Editor' because it may be damaged or incomplete."

EDIT: After a conversation with Khoth, I did a find-replace of "UCHAR" for "unsigned char," at which point the build worked. Now what?

EDIT 2: It appears that my computer has some sort of serious internal error. Thanks guys, but I don't think we can solve it here.

[ Saturday, July 23, 2005 12:49: Message edited by: Kelandon ]

--------------------
Arancaytar: Every time you ask people to compare TM and Kel, you endanger the poor, fluffy kittens.
Smoo: Get ready to face the walls!
Ephesos: In conclusion, yarr.

Kelandon's Pink and Pretty Page!!: the authorized location for all things by me
The Archive of all released BoE scenarios ever
Posts: 7968 | Registered: Saturday, February 28 2004 08:00
? Man, ? Amazing
Member # 5755
Profile #12
That'll teach ya to go messin about with strange new coding techniques.

I also think that none of us are supposed to see how badly the BoE/BoA conversion of VoDT actually went.

*this message sponsored by the magical waste disposal company - stored in computers too*

--------------------
WWtNSD?
Posts: 4114 | Registered: Monday, April 25 2005 07:00
Shock Trooper
Member # 4557
Profile #13
quote:
Originally written by Kelandon:


EDIT 2: It appears that my computer has some sort of serious internal error. Thanks guys, but I don't think we can solve it here.

If you ever do find out what the problem is, could you post it? It seems odd that an internal error would only affect BoA/Editor.
Posts: 264 | Registered: Wednesday, June 16 2004 07:00
Off With Their Heads
Member # 4045
Profile Homepage #14
It screws up anything that uses sound resource files, but few things actually do. Khoth suggested I check Escape Velocity, and EV runs, but the sound is completely messed up.

So whatever it is, it's messing with sound resources.

--------------------
Arancaytar: Every time you ask people to compare TM and Kel, you endanger the poor, fluffy kittens.
Smoo: Get ready to face the walls!
Ephesos: In conclusion, yarr.

Kelandon's Pink and Pretty Page!!: the authorized location for all things by me
The Archive of all released BoE scenarios ever
Posts: 7968 | Registered: Saturday, February 28 2004 08:00
Shock Trooper
Member # 4557
Profile #15
Well there's some good news in that. Since you can build the editor's source code, you should be able to get rid of sound in the editor (I can tell you what to do if you want to) and get that to work. Also, you can manually go into BoA's preference file and turn the sound off (with a Hex Editor) to get BoA working. This might help, in case fixing the bug takes longer than expected.
Posts: 264 | Registered: Wednesday, June 16 2004 07:00
Off With Their Heads
Member # 4045
Profile Homepage #16
Okay, Apple has now claimed that sound resources are "third-party software," so they cannot provide any technical support. Additionally, because the operating system CDs that I have are scratched, I apparently have to buy the CDs over again in order to re-install my system software.

Other than blowing eighty bucks for a fix that may or may not actually change anything, anyone have any ideas? Like, for instance, who might actually offer technical support on this?

The problem is that sound resource files no longer play properly on my computer. SW games crash, and EV's sound is completely jacked up. I listen to sound resources in ResEdit, and they sound staticky and bad.

EDIT: Actually, it's all sound in Classic mode. I finally managed (on the third try) to get someone at Apple tech support who knows what he's talking about. This ought to be interesting.

[ Sunday, July 24, 2005 14:31: Message edited by: Kelandon ]

--------------------
Arancaytar: Every time you ask people to compare TM and Kel, you endanger the poor, fluffy kittens.
Smoo: Get ready to face the walls!
Ephesos: In conclusion, yarr.

Kelandon's Pink and Pretty Page!!: the authorized location for all things by me
The Archive of all released BoE scenarios ever
Posts: 7968 | Registered: Saturday, February 28 2004 08:00
Shock Trooper
Member # 4557
Profile #17
quote:
Originally written by Kelandon:

Okay, Apple has now claimed that sound resources are "third-party software," so they cannot provide any technical support.
The sound resources aren't corrupt, the part of OS X that loads/plays them is. Fixing this is Apple's responsibility. Perhaps you should explain this to them.

If they still refuse to help, I googled OS X Support, and got this site:
http://www.macosx.com/

Seems promising.
Posts: 264 | Registered: Wednesday, June 16 2004 07:00
Off With Their Heads
Member # 4045
Profile Homepage #18
Okay, WOW. My computer is messed up. After determining that it was all sound in Classic mode, not just snd resources, they decided that they could help me, and I just spent the past four hours talking to five different tech support people who made me do everything from re-installing Classic to running a Disk Repair to screwing with every possible aspect of Quicktime, and it still doesn't work. They're sending me to the higher-ups in the Apple tech support world, the people who don't normally even speak to customers.

My SW game-playing may be somewhat reduced for some time until they can figure this out.

--------------------
Arancaytar: Every time you ask people to compare TM and Kel, you endanger the poor, fluffy kittens.
Smoo: Get ready to face the walls!
Ephesos: In conclusion, yarr.

Kelandon's Pink and Pretty Page!!: the authorized location for all things by me
The Archive of all released BoE scenarios ever
Posts: 7968 | Registered: Saturday, February 28 2004 08:00
Off With Their Heads
Member # 4045
Profile Homepage #19
God only knows why, but this fixed my problem.

Everything works fine now. :confused:

--------------------
Arancaytar: Every time you ask people to compare TM and Kel, you endanger the poor, fluffy kittens.
Smoo: Get ready to face the walls!
Ephesos: In conclusion, yarr.

Kelandon's Pink and Pretty Page!!: the authorized location for all things by me
The Archive of all released BoE scenarios ever
Posts: 7968 | Registered: Saturday, February 28 2004 08:00
Warrior
Member # 5986
Profile #20
quote:
Originally written by Kelandon:

God only knows why, but this fixed my problem.

Everything works fine now. :confused:

Yeah, I thought the same thing when I first tried it. It was in a couple of obscure posts on the Classic tech support forums at Apple. The method might seem silly, but it also seems to work. Perhaps the tech support guys at Apple should read the forums more often. :P

Isn't life wonderfully ironic?

[ Wednesday, July 27, 2005 01:45: Message edited by: Slp006 ]

--------------------
Wu wei... it's the only way
Posts: 154 | Registered: Monday, June 20 2005 07:00
Triad Mage
Member # 7
Profile Homepage #21
It could make sense - maybe GarageBand initializes sounds and cleared out the badness?

--------------------
"At times discretion should be thrown aside, and with the foolish we should play the fool." - Menander
====
Drakefyre's Demesne - Happy Happy Joy Joy
Encyclopedia Ermariana - Trapped in the Closet
====
You can take my Mac when you pry my cold, dead fingers off the mouse!
Posts: 9436 | Registered: Wednesday, September 19 2001 07:00
Infiltrator
Member # 148
Profile #22
I just wish I had GarageBand. :(

--------------------
My ego is bigger than yours.
Posts: 480 | Registered: Thursday, October 11 2001 07:00