Strength 0 in MoC

AuthorTopic: Strength 0 in MoC
Apprentice
Member # 6105
Profile #0
A couple of really strange things happened to me Beneath the Citadel in Magus of Cattalon, and I'm hoping someone can help me figure them out.

First, there is an arena to the southwest where you are supposed to be able to train. If I entered the room through the western doors, the 'Info' button would switch to 'Train' for just an eyeblink, but then immediately reset to 'Info.' If I stepped back onto one of the four special encounter squares from inside the room, it would change to 'Train' and stay that way for a while, but as I moved around in the room - away from either set of doors - it would sometimes revert. This was erratic but it occurred several times. If my party moved from south to north right next to the doors, it would consistently revert to 'Info' when my leader was on the second encounter square and my second character on the first.

I thought that was weird, and looking at the scripts I couldn't see any reason for it, but things soon got much worse.

As I walked through the long room with the Naga statues, I was cursed and slowed. OK, I can deal with that, but it kept on happening every few turns as I moved into other areas. I was not doing much damage at all in combat, and I thought it must just be a really bad curse - until I tried to pick something up and discovered that my weight limit had dropped to 66 lbs! My strength was down to O (from 18-20 for my fighters, 7 or 8 for my spellcasters). This freaked me out, and frankly made me pretty angry, and I immediately quit the game.

A little later, feeling calmer, I tried to understand what had happened. As far as I can tell, the curse was only supposed to affect statuses 1 and 3, and furthermore should have stopped when I stepped out of the room with the statues, but it didn't. My characters' Strength dropped by 8 points each time I was cursed, until it hit 0, but according to the Editor docs, it's not supposed to be possible for Strength to go below 1.

Finally, going back to the arena and reading the training book restored the missing skill points, which makes me think this was all intentional - but I can't find anything in the scripts to account for it.

I should emphasize that until now I knew NOTHING about scripting, so it's very possible there is more going on than I am getting. I am actually pleased this happened, because for the first time I can look at a script and make some sense of it - not much so far, but some. A couple of times since Blades was released, I had wanted to learn how to build my own scenarios. Unfortunately I have no coding experience and everything I read was just gibberish to me, so I didn't get very far. Coming at it backwards, as it were, has somehow enabled me to cross that threshold, and I have started reading the manuals and playing with the Editor. Who knows how far it will go? But if someone can help me understand this, it will encourage me to keep learning.

--------------------
Lucidus
Posts: 29 | Registered: Wednesday, July 13 2005 07:00
Shaper
Member # 7472
Profile Homepage #1
Were you enfeebled?

Enfeeblement (represented by a skull in your status roster) directly reduces your strength for a brief period of time. Each level knocks strength down by one. That said, if this isn't the case, you might want to check to see if you have the most recent version of the scenario.

--------------------
Hz'ii'zt a'iiencf coxnen a'bn'z'p pahuen yzpa'zuhb be'tt'phukh'kn az'ii'ova mxn't bhcizvi'fl?

Nioca's Citadel - A resource for BoA graphics and scripts, as well as my scenarios.
In Last Hope's Light RP - The end is near...
Posts: 2686 | Registered: Friday, September 8 2006 07:00
Shock Trooper
Member # 7662
Profile #2
Now the training is easy to explain, if this is town 18 that we are discussing then it is affected by the call: "turn_off_training(1);", which makes training impossible anywhere in the town. However there is also an exception made to this: when you enter the room. This is then countermanded when you leave the room. Then the Start State has this call too!? So the training works in the way that it is meant to.

The Start State is activated every round, if you received a message like this "A strange hissing fills your ears. You feel very bad.", your party had just been enfeebled.

[ Monday, January 21, 2008 22:11: Message edited by: Ishad Nha ]
Posts: 292 | Registered: Monday, November 13 2006 08:00
Apprentice
Member # 6105
Profile #3
You are absolutely correct about the enfeeblement, and I feel foolish for not having recognized it. However, my Strength was not being gradually restored, as it should have been with enfeeblement, so there was still something seriously wrong.

I looked to see if a more recent version was available, and couldn't find one, although it's hard to be certain. (Does anyone else think it would be a Very Good Thing if there were some standard way of indicating the version of a scenario? Even something as simple as including the version number in the name of the parent folder would suffice, if everybody did it.)

So I downloaded the scenario again, just in case, and got an error message when I tried to expand the .sit archive. This had also happened a few of times while I was gathering scenarios last week, and I thought I had discarded the ones that might have had problems, but maybe I missed some. The latest version of Stuffit Expander still did the same thing, but The Unarchiver (when I finally found a copy - the main site has been down) worked just fine. I know Stuffit is becoming a problem (a shame, really); perhaps The Unarchiver should be mentioned in the forum header or the FAQ, to help others avoid this problem. I'll suggest this to Spiderweb as well, for their scenario download page.

Anyway - with the new copy, things seem to be working as they should, so your suggestion definitely helped me figure it out. Thanks.

--------------------
Lucidus
Posts: 29 | Registered: Wednesday, July 13 2005 07:00
Off With Their Heads
Member # 4045
Profile Homepage #4
quote:
Originally written by Lucidus:

Does anyone else think it would be a Very Good Thing if there were some standard way of indicating the version of a scenario? Even something as simple as including the version number in the name of the parent folder would suffice, if everybody did it.
I think most designers use the "version" field in the editor. However, checking it requires actually opening the scenario in the editor and looking at "Basic Scenario Details" in the Scenario menu, which is not very player-friendly.

All of my scenarios have the version number in the readme, too, but this is not a universal practice.

--------------------
Arancaytar: Every time you ask people to compare TM and Kel, you endanger the poor, fluffy kittens.
Smoo: Get ready to face the walls!
Ephesos: In conclusion, yarr.

Kelandon's Pink and Pretty Page!!: the authorized location for all things by me
The Archive of all released BoE scenarios ever
Posts: 7968 | Registered: Saturday, February 28 2004 08:00