Can't turn on Debug Mode?

Error message

Deprecated function: implode(): Passing glue string after array is deprecated. Swap the parameters in drupal_get_feeds() (line 394 of /var/www/
AuthorTopic: Can't turn on Debug Mode?
Member # 4258
Profile #0
In the docs it says that the call turn_on_debug_mode() should activate debug mode... But when I try to use it I get the error: "Unknown command turn_on_debug_mode in line 29." This is using Mac version 1.1.

Posts: 28 | Registered: Wednesday, April 14 2004 07:00
Member # 154
Profile #1
Perhaps you have to put it in the scenario START_STATE?

Once turn_on_debug_mode() has been called, you need to activate it by pressing } and =.

Apparently still annoying.
Posts: 612 | Registered: Saturday, October 13 2001 07:00
Member # 4202
Profile Homepage #2
No, I've gotten the same error. Unknown command! The game doesn't even know what it is supposed to mean, so of course pressing those keys won't make any difference. And if it were in th wrong script, it would give a different error or none at all. For example, run_town_script produces an error something like:

run_town_script can't be called from a scenario script

or, move_to_new_town in a creature script does nothing and produces no error. But turn_on_debug_mode is nonsense to the game's Avernumscript interpreter, hence the error.

I want turn_on_debug_mode!

I've also tried pressing those keys without calling turn_on_debug_mode, and it doesn't work.

[ Sunday, June 06, 2004 00:32: Message edited by: Isaac ]

Creator of the 3D Blades of Avernum Editor for Mac. Get it at Ingenious Isaac's Illusion, my web page. Better yet, get Battle for Wesnoth, a wonderful free TBS game.
Posts: 192 | Registered: Sunday, April 4 2004 08:00
Member # 4506
Profile Homepage #3
I have the same problem - working on Windows 98SE. It just gives me an error. If anyone knows how to fix it could you please email me how it works. FOR WINDOWS please, I don't neeed to know how to make Mac's work.

[ Thursday, June 10, 2004 23:51: Message edited by: Micael 456 ]

"You dare Trifle with Avernum?" ~ Erika the Archmage
My Scenarios:
Undead Valley : A small Undead problem, what could possibly go wrong?
Richard Black - PROOF of his existance (the Infernal one's website).
MY FORUM! Randomosity at it's highest! :)
Posts: 1370 | Registered: Thursday, June 10 2004 07:00
Member # 869
Profile Homepage #4
I don't think anyone can make debug mode work. It seems to be just plain broken.

The Empire Always Loses: This Time For Sure!
Posts: 9973 | Registered: Saturday, March 30 2002 08:00