Geneforge XP compatability issues?

Error message

Deprecated function: implode(): Passing glue string after array is deprecated. Swap the parameters in drupal_get_feeds() (line 394 of /var/www/
AuthorTopic: Geneforge XP compatability issues?
Member # 1565
Profile #0
Am I the only person who has run into stability issues while running Genefore in Win XP?

I was having problems with my computer randomly restarting on me due to fatal errors. At first I assumed it was due to my modem, but the number of crashes went dramatically up if I played Geneforge that day.

A few days ago I finally uninstalled the game and I've had almost no problems with my comp since, which confirms my suspicions that most of the problems lie with the game.

So, is it my computer being a yutz and just not caring for the game, or have other XP gamers had problems like this? If it just me, does anyone have any ideas for how to fix it? Has anyone tried using the emulation in XP that lets the game thing it's in a different OS?

I'd really like to be able to reinstall the game because I love this game. :-/
Posts: 5 | Registered: Saturday, July 20 2002 07:00
Member # 3
Profile #1
I've not had any problems with XP and Geneforge, but I haven't played it excessively on XP. It sounds like you probably are having a driver problem of some sort. Do you have similar problems after playing other games?

A few cats short of a kitten pot pie...

Radioactive cats have 18 half-lives.
Check out a great source for information on Avernum 2, Nethergate, and Subterra: Zeviz's page.
Finally, there's my Geneforge FAQ, Geneforge 2 FAQ, and
Geneforge 3 FAQ.
Posts: 2831 | Registered: Tuesday, September 18 2001 07:00
Member # 1565
Profile #2
Yeah. I'm pretty sure my modem is part of the problem, yet I can play other games with no problems what so ever.

There were three things I was thinking I were the culprit.

1. The modem. I don't really have the money to spend on a new one (although I know generic ones are dirt cheap)

2. An anti-virus program. My computer hates these things. I've had the worse luck with them, which is why they don't usually stay on my system long. Unintalling it took care of many, but not all of the problems.

3. Geneforge. It's the only other fairly big program I've installed on my computer lately.

Since I uninstalled the game on 8-11, I haven't had a single crash. While playing Geneforge religiously (several hours a day, I admit. Hey, I'm on break), I'd crash at least once, if not two-three times a day.

So I'm guessing the game is it because I can't think of anything else.
Posts: 5 | Registered: Saturday, July 20 2002 07:00
Member # 760
Profile #3
weird thing I havent got any problems with Geneforge on my XP......have you tried to change conditition where it runs for Win 9x, ME or 2000 in the EXEs properties?

"The Darkness Shall Return!"
Posts: 642 | Registered: Saturday, March 16 2002 08:00
Member # 1150
Profile Homepage #4
Geneforge on XP seems to require a terribly large amount of memory/video ram. Perhaps your computer doesn't have enough of those two resources to run both Geneforge AND XP, which is a demanding interface.

Also, make sure you don't have any of those huge wallpapers on your desktop, and not an active one; active desktops and spidweb games do not get along well together most of the time. Screen savers, even when idle, seem to conflict with Spidweb games also.

"To sit in solemn silence on a dull dark dock/in a pestilential prison with a lifelong lock/awaiting the sensation of a short sharp shock/from a cheap and chippy chopper on a big black block."
Visit The Kavern webpage, host of Phoenix and Polaris, and home of a soon-to-be famous writing center!
Posts: 975 | Registered: Tuesday, May 14 2002 07:00
Member # 1248
Profile #5
GeneForge doesn't run at all on my Windows 98. GeneForge only seems to work on my Mac OS X, but not Mac OS 9...tis strange, no?

Tails MSN Hot-Mail Address ---
Posts: 455 | Registered: Saturday, June 1 2002 07:00
Member # 2023
Profile #6
A few suggestions.

First, check out AVG, a free antivirus program available at I've used it on Win98, 98SE, 2000, and XP on a variety of computers, with no significant problems (unless you're having it check all Outlook Express email, and using OE to read Hotmail accounts).

Second, there's a good chance the problem is your DirectX drivers. Try downloading the newest drivers for your video card, especially if you've upgraded DirectX, especially if you upgraded to a beta. If this is the problem, it's easily possible that all kinds of other programs might work fine, including non-DirectX games or even DirectX games that don't use the one particular feature that's buggy on your system.

Third, you could have a bad memory chip, or just a badly-seated memory chip. This can cause intermittent problems that usually show up only when you stress the computer in certain ways (by running a memory-intensive game, for example), and won't show up during the Power-On Self-Test. There are about a billion free memory test programs out there; do some research and find a good one. I have a linux box that would usually fail when recompiling the kernel, but would almost never fail when doing anything else, and I eventually tracked the problem down to a very-intermittently-bad memory chip.

Finally, if you really think the modem is the issue, completely disable it, uninstall the drivers, and disconnect it from your computer, and see if GeneForge still causes problems for you. If uninstalling your modem fixes everything, and you can't afford the $12 for a new modem (or $5 for a used one), then try reinstalling the drivers (and check to see if there are specific drivers for your modem, although most don't have them). Also, see if there's anything funky in your BIOS settings relating to the modem or the com ports.

Hope this helps.
Posts: 14 | Registered: Friday, October 4 2002 07:00
Member # 2023
Profile #7
Originally posted by Tails:
GeneForge doesn't run at all on my Windows 98. GeneForge only seems to work on my Mac OS X, but not Mac OS 9...tis strange, no?
A lot of carbonized apps have problems on OS 9. Make sure you've upgraded both MacOS to the latest version, and that you have the latest CarbonLib. Even still, I've had a few bizarre problems (like crashing when I try to open the instructions, or not responding to the keys in the two columns starting with 9 and 0). Maybe the older (non-Carbon) version will work? I haven't tried that yet.
Posts: 14 | Registered: Friday, October 4 2002 07:00