Avernum I "DEBUG" mode?

Error message

Deprecated function: implode(): Passing glue string after array is deprecated. Swap the parameters in drupal_get_feeds() (line 394 of /var/www/pied-piper.ermarian.net/includes/common.inc).
AuthorTopic: Avernum I "DEBUG" mode?
Member # 3813
Profile Homepage #0
Anyone know what's up with the "DEBUG" mode in Avernum I? I think I entered by hitting the caps lock key (MacOS 10.4.5) accidentally, then the "e" key when I tried to exit combat. Everytime I accessed the "e" key the following text was displayed, in bold red text "DEBUG: ADD XP." When I tried to look into a container with the "L" key it read ""DEBUG: GET AN ITEM."

I can't replicate it, so I'm guessing it resulted from hitting the caps lock key.

Game seems fine, just curious.

- Joel
Posts: 33 | Registered: Monday, December 22 2003 08:00
Member # 869
Profile Homepage #1
Wouldn't surprise me. Lots of SW games have debug commands that can be accessed by typing an uppercase letter.

The Empire Always Loses: This Time For Sure!
Posts: 9973 | Registered: Saturday, March 30 2002 08:00
Law Bringer
Member # 4153
Profile Homepage #2
Yeah, I believe the customary way of triggering it is "shift+(whatever letter)", but I suppose caps lock would have the same effect.

Try other letters and see what you get. :D

Gamble with Gaea, and she eats your dice.

I hate undead. I really, really, really, really hate undead. With a passion.
Posts: 4130 | Registered: Friday, March 26 2004 08:00